PHO - Pokémon Hackers Online
Go Back   PHO - Pokémon Hackers Online > Homebrew & Coding > Coding Discussion

Coding Discussion Discuss programming and coding and get help here.

Reply
 
Thread Tools Display Modes
Old 19th September 2014, 10:44 PM   #11
TNTftw21
Neophyte
 
Join Date: Jun 2014
Posts: 12
TNTftw21
Default

Thanks. You were right, cli was working. However, installing python3-PyQt4 lead to another error:
Code:
[((omitted))@localhost red-alien-master]$ asc-qt --help
Traceback (most recent call last):
  File "/usr/bin/asc-qt", line 2, in <module>
    from asc.asc_qt import main
  File "/usr/lib/python3.3/site-packages/asc/asc_qt.py", line 8, in <module>
    from .qtgui import Ui_MainWindow
  File "/usr/lib/python3.3/site-packages/asc/qtgui.py", line 146, in <module>
    from PyQt4 import Qsci
ImportError: cannot import name Qsci
**UPDATE**

After attempting to bring up one of my maps (for a fresh ROM, only the file was renamed), doing
Code:
./bluespider-cli (rom) 1 0
, I get this:
Code:
Warning: Couldn't import PIL
Traceback (most recent call last):
  File "./bluespider-cli", line 3, in <module>
    main()
  File "/home/tony/blue-spider-master/bluespider/mapped_text.py", line 32, in main
    rom_code = get_rom_code(rom_contents)
NameError: global name 'get_rom_code' is not defined
However, I'm not completely enraged about this, due to the fact that, even though it's supposed to be command line, I wasn't expecting to be able to do anything without getting the GUI running.

Last edited by TNTftw21; 19th September 2014 at 10:56 PM.
TNTftw21 is offline   Reply With Quote
Sponsored Links
Old 20th September 2014, 12:40 AM   #12
cosarara
Programming and asdf
 
cosarara's Avatar
 
Join Date: Sep 2014
Location: Near Barcelona
Age: 19
Posts: 12
cosarara
Default

Quote:
Originally Posted by TNTftw21 View Post
Thanks. You were right, cli was working. However, installing python3-PyQt4 lead to another error:
Code:
[((omitted))@localhost red-alien-master]$ asc-qt --help
Traceback (most recent call last):
  File "/usr/bin/asc-qt", line 2, in <module>
    from asc.asc_qt import main
  File "/usr/lib/python3.3/site-packages/asc/asc_qt.py", line 8, in <module>
    from .qtgui import Ui_MainWindow
  File "/usr/lib/python3.3/site-packages/asc/qtgui.py", line 146, in <module>
    from PyQt4 import Qsci
ImportError: cannot import name Qsci
**UPDATE**

After attempting to bring up one of my maps (for a fresh ROM, only the file was renamed), doing
Code:
./bluespider-cli (rom) 1 0
, I get this:
Code:
Warning: Couldn't import PIL
Traceback (most recent call last):
  File "./bluespider-cli", line 3, in <module>
    main()
  File "/home/tony/blue-spider-master/bluespider/mapped_text.py", line 32, in main
    rom_code = get_rom_code(rom_contents)
NameError: global name 'get_rom_code' is not defined
However, I'm not completely enraged about this, due to the fact that, even though it's supposed to be command line, I wasn't expecting to be able to do anything without getting the GUI running.
ASC (red alien) needs python3-qscintilla too. It should say so in the README, and if it doesn't it's totally my fault
For blue spider you'll also need an Image library for python 3 (usually Pillow or PIL).

Are you pulling from the git repo or you downloaded a tarball?
cosarara is offline   Reply With Quote
Old 20th September 2014, 02:48 AM   #13
Gamer2020
What does this button do?.....
PHO VIP
 
Gamer2020's Avatar
 
Join Date: Jun 2010
Posts: 85
Gamer2020
Default

Get the latest version of Github here: https://github.com/Gamer2020/PokemonGameEditor/

Take a look at the recommended tool list.
__________________
Pokemon Game Editor download!
Gamer2020 is offline   Reply With Quote
Old 20th September 2014, 03:33 PM   #14
TNTftw21
Neophyte
 
Join Date: Jun 2014
Posts: 12
TNTftw21
Default

Quote:
Originally Posted by cosarara View Post
ASC (red alien) needs python3-qscintilla too. It should say so in the README, and if it doesn't it's totally my fault
For blue spider you'll also need an Image library for python 3 (usually Pillow or PIL).

Are you pulling from the git repo or you downloaded a tarball?
It was in the README, but I think what happened was that I checked for it in yum and it didn't come up (not realizng that the packages I needed where qscintilla and qscintilla-python (the only PyQt4 package). Due to this error (it seems to me that these names are either for apt-get in Debian or for the Arch repository), I have started writing down the packages needed, and, with your permissions, post a link to the README with the names of the packages in Fedora and (using a VM to get it to work possibly) the package names in Debian. I am pulling from the git repo, as that's where the Blue Spider and Red Alien links took me to from your website.

Also, even though I have said packages, it still says that it can't import Qsci. Do I need the devel package or something?

**UPDATE**

I forgot to install pillow and check Blue Spider, but (after installing the python3-pillow-qt, no duh) now the GUI comes up! Thanks for your help on that part! Now my only question is, why do you have adding map banks if you can't add maps? Where you expecting us to know how to do that?

Quote:
Originally Posted by Gamer2020 View Post
Get the latest version of Github here: https://github.com/Gamer2020/PokemonGameEditor/

Take a look at the recommended tool list.
As I said a couple of posts ago, I found a working Windows version. However, I will take a look at this anyway. Thanks for your help.

The tool list only helped with SEA, as I already have no$GBA and MEH. (Although MEH looks pretty good so far, I'm having to stick with A-Map for a bit longer - at least until they add being able to add maps to the ROM, which I have NO idea how to do.) The others I do't think I can use, due to requirements for Microsoft Studio 2010. Ah, well. You probably already knew all that.

Last edited by TNTftw21; 20th September 2014 at 03:48 PM.
TNTftw21 is offline   Reply With Quote
Old 20th September 2014, 07:22 PM   #15
cosarara
Programming and asdf
 
cosarara's Avatar
 
Join Date: Sep 2014
Location: Near Barcelona
Age: 19
Posts: 12
cosarara
Default

Quote:
Originally Posted by TNTftw21 View Post
It was in the README, but I think what happened was that I checked for it in yum and it didn't come up (not realizng that the packages I needed where qscintilla and qscintilla-python (the only PyQt4 package). Due to this error (it seems to me that these names are either for apt-get in Debian or for the Arch repository), I have started writing down the packages needed, and, with your permissions, post a link to the README with the names of the packages in Fedora and (using a VM to get it to work possibly) the package names in Debian.
That's perfectly fine, we can put it in the official README.

Quote:
Originally Posted by TNTftw21 View Post
I am pulling from the git repo, as that's where the Blue Spider and Red Alien links took me to from your website.

Also, even though I have said packages, it still says that it can't import Qsci. Do I need the devel package or something?
You have to make sure it's the python 3 version
qscintilla-python sounds very like the python 2 version. (My google-fu says there should be a python3-qscintilla in fedora).

Quote:
Originally Posted by TNTftw21 View Post
**UPDATE**

I forgot to install pillow and check Blue Spider, but (after installing the python3-pillow-qt, no duh) now the GUI comes up! Thanks for your help on that part! Now my only question is, why do you have adding map banks if you can't add maps? Where you expecting us to know how to do that?
There are lots of things missing from blue spider. Adding maps, proper level script editing, an undo/redo system, wild pokemon editing, etc. It's more or less enough for me, since I don't ROM Hack seriously, though.
(On the other side, Red Alien is awesome IMO)
cosarara is offline   Reply With Quote
Old 20th September 2014, 07:32 PM   #16
Gamer2020
What does this button do?.....
PHO VIP
 
Gamer2020's Avatar
 
Join Date: Jun 2010
Posts: 85
Gamer2020
Default

Quote:
Originally Posted by TNTftw21 View Post
As I said a couple of posts ago, I found a working Windows version. However, I will take a look at this anyway. Thanks for your help.

The tool list only helped with SEA, as I already have no$GBA and MEH. (Although MEH looks pretty good so far, I'm having to stick with A-Map for a bit longer - at least until they add being able to add maps to the ROM, which I have NO idea how to do.) The others I do't think I can use, due to requirements for Microsoft Studio 2010. Ah, well. You probably already knew all that.
Well this is the latest version so that's why I linked it. Also the programs on the recommended tool list should all run on Linux.
__________________
Pokemon Game Editor download!
Gamer2020 is offline   Reply With Quote
Old 20th September 2014, 09:26 PM   #17
TNTftw21
Neophyte
 
Join Date: Jun 2014
Posts: 12
TNTftw21
Default

Quote:
Originally Posted by cosarara View Post
That's perfectly fine, we can put it in the official README.


You have to make sure it's the python 3 version
qscintilla-python sounds very like the python 2 version. (My google-fu says there should be a python3-qscintilla in fedora).


There are lots of things missing from blue spider. Adding maps, proper level script editing, an undo/redo system, wild pokemon editing, etc. It's more or less enough for me, since I don't ROM Hack seriously, though.
(On the other side, Red Alien is awesome IMO)
Okay, thanks. I can't seem to find python3-qscintilla, but I'll look for it anyway. The Fedora Project says that python3-qscintilla is part of the qscintilla package, but it obviously isn't. Could you give a link to the page you found this information at?

**UPDATE**

I checked Fedora Project again, and it turns out that python3-qscintilla will be available as of Fedora 21 (which is currently in testing, scheduled to come out in December). This means that (currently) there is no python3-qscintilla for stable Fedora. So, to save time, I will see if I can find a legal Ubuntu iso (since I don't know if you have to pay for it) to run this stuff on.

**UPDATE 2**

Just my luck, VirtualBox is continuously crashing.

Quote:
Originally Posted by Gamer2020 View Post
Well this is the latest version so that's why I linked it. Also the programs on the recommended tool list should all run on Linux.
Okay, I'll try them. Thanks again.

***UPDATE***
All of the programs that require Visual Studio 2010 are throwing errors, and I can't seem to get Visual Studio 2010. Which doesn't surprise me, considering that it's Microsoft :P

Last edited by TNTftw21; 25th October 2014 at 06:03 PM.
TNTftw21 is offline   Reply With Quote
Reply

Tags
pge, playonlinux

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc. User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Pokémon characters and images belong to Pokémon USA, Inc. and Nintendo.
Pokémon Hackers Online (PHO) is in no way affiliated with or endorsed by Nintendo LLC, Creatures, GAMEFREAK inc,
The Pokémon Company, Pokémon USA, Inc., The Pokémon Company International, or Wizards of the Coast.
All forum/site content (unless noted otherwise) and site designs are © 2006-2013 Pokémon Hackers Online (PHO).
Green Charizard Christos TreeckoLv100

"Black 2" by ARTPOP. Kyurem artwork by XOUS.

no new posts